Microsoft Outlook
Incident Report for Potter Clarkson
Resolved
This incident has been resolved.
Posted Jun 15, 2020 - 19:49 BST
Identified
Microsoft have announced that there is an issue accessing email from within the Outlook client. Access via Outlook on the Web is not affected.
Posted Jun 15, 2020 - 15:14 BST
This incident affected: Office 365.