Users may be unable to access multiple Microsoft 365 services
Incident Report for Potter Clarkson
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 13:28 GMT
Investigating
We have been made aware that Microsoft are experiencing issues with multiple Microsoft 365 services. As a result, you may experience poor performance or be unable to access applications such as Outlook, Teams and R3. This issue is being treated with the highest priority and we will provide further communication when this has been resolved.
Posted Jan 25, 2023 - 07:59 GMT
This incident affected: R3 and Office 365.