Outbound email processing issues
Incident Report for Potter Clarkson
Resolved
This incident has been resolved.
Posted Sep 15, 2020 - 08:41 BST
Identified
Some of your external recipients may experience a delay in receiving your email due to a processing delay. We're currently investigating this problem.
Posted Sep 14, 2020 - 15:23 BST
This incident affected: Office 365.