Rosetta - Unplanned Disruption
Incident Report for Potter Clarkson
Resolved
This incident has been resolved.
Posted Jul 25, 2022 - 09:18 BST
Investigating
We are currently experiencing an unplanned technical issue affecting Rosetta2 and R3.
Posted Jul 25, 2022 - 09:03 BST
This incident affected: R3 and Rosetta 2.