Can't access multiple Microsoft 365 services
Incident Report for Potter Clarkson
Resolved
This incident has been resolved.
Posted May 11, 2020 - 16:05 BST
Identified
Microsoft are investigating an access issue affecting multiple services including Office 365 and Teams.
Posted May 11, 2020 - 14:53 BST
This incident affected: Office 365.