Prompt updates in R3
Incident Report for Potter Clarkson
Resolved
This incident has been resolved.
Posted Apr 18, 2023 - 17:10 BST
Investigating
We are aware of an ongoing issue affecting prompt updates on R3. This is due to an error within our K2 system and has been escalated to their support team to be investigated.
Posted Mar 30, 2023 - 10:58 BST
This incident affected: R3 and K2.