Ongoing Microsoft Outlook Issue
Incident Report for Potter Clarkson
Update
We are continuing to investigate this issue.
Posted Oct 04, 2024 - 12:18 BST
Update
We are continuing to investigate this issue.
Posted Oct 04, 2024 - 12:17 BST
Investigating
We’re aware that a small number of users are encountering issues with emails getting stuck in the outbox within Outlook.

We are actively investigating the situation with our partners at Microsoft to identify the root cause and implement a resolution. We appreciate your patience as we work to resolve this promptly.
Posted Oct 04, 2024 - 12:00 BST
This incident affects: Office 365.